Git PPA for Ubuntu

I maintain a git PPA for Ubuntu which is hosted at Launchpad. I try to build packages of the latest git within a few days after it’s official release but sometimes other work takes priority, like work I get paid for. The official homepage of git can be found at where you can find the release notes of git, as well as several links to documentation on working with git.

Depending on the updated release, I will announce updates on this blog and/or through my twitter account @avhsoftware.

Current version: 1.9.2

Git is available for the following Ubuntu distributions:

  • Ubuntu 14.04 (Trusty)
  • Ubuntu 13.10 (Saucy)
  • Ubuntu 12.10 (Quantal)
  • Ubuntu 12.04 (Precise)

To add my Ubuntu git PPA to your system follow these instructions:

sudo add-apt-repository ppa:pdoes/ppa


The creation of the git packages for Ubuntu is done in my spare time. If you use the packages please consider a donation. There are several ways you can show your appreciation:

  • Amazon Wish List
    You can send me something from my Amazon Wish List.
  • Through Paypal.
    Click on the Donate button and you will be directed to Paypal where you can make your donation and you don’t have to have a Paypal account.
  • Millisami

    Does this work with Ubuntu Lucid Lynx ??

  • Yes it should. I added Lucid yesterday. Thank you for the comment, it showed me to update the page

    • Abhinav

      please update the page with Lucid. As Lucid is only lts right now, most of the custom kernel updaters are on Lucid.

      Thanks for sharing your work.


      • Peter

        There are unmet dependencies when building for Lucid. I won’t be building for Lucid anymore.

        • flexic

          Since you won’t be building for Lucid anymore, do you have any thoughts on the easiest way to install/update git on 10.04 from here on out?

          • Peter

            OK two people asked, so what can I do 🙂

            I uploaded git v1.7.9.2 to be build for Ubuntu 10.04. As I’m writing this the 64bit version is building, and the ETA for the i386 build to start is 5 hours, so be patient, cross your fingers, install it and let me know it it worked 🙂

          • flexic

            I just checked for updates on my server and noticed git was available! A nice surprise, thanks for building this version for Lucid Peter we really appreciate it.

            When Ubuntu 12.04 LTS is released we’ll look at upgrading but it’s nice to have git for the last LTS release still available, thanks to you

          • Peter


            So I can assume it’s working.
            I changed the way I prepare my builds a bit and it won’t be hard to keep the version updated right now.

          • flexic

            Yes I should have mentioned it is working great (using v1.7.9.3). Have it running on our local Lucid server with all development being pushed through gitolite to it. Thanks again for adding Lucid back to your builds!

  • Evan Scott

    Is your key server up? I am getting a timout from the apt-key command?


    • Lorne

      Key server still appears to be down or is down again.

      • I added a new way to add my repository. Check to see if this will get you the key. The keyserver is not administrated by me but by Canonical, so unfortunately there’s not much I can do when it’s down.

  • ninja overlord

    What is the name of the package which we should apt-get once we’ve added your repository?

    • Depending on which Ubuntu version, prior to Lucid it would be git-core and starting with Lucid you can use git.

  • tebee

    Following your instruction i got successful prompt.
    What could i have into /var/lib/apt/lists directory?

    Further, i am following “How to compile.. 10.10 kernel” and the preparation step
    apt-get build-dep linux
    and it gives a error of missing:

    Where i am wrong?

    • It looks like a typo, it’s maverick not mawerick.

  • Installed great. The easiest install ever. I just posted an article about your repository. Thanks so much.

  • buffalobillion

    Thanks, man! You saved my bacon having this ppa available.

  • Dariusz Kordonski

    Thanks man, that’s gold!

  • Fredrik Lundström


    I’ve changed from Ubuntu 10 to Ubuntu 11.10, but after I did apt-get install git, I found out it still was too old, so I once again needed to upgrade git to >= 1.7.6.

    A few months ago, the suggestion “sudo add-apt-repository ppa:pdoes/ppa/ubuntu” worked, but now, the URL seems to be changed to “sudo add-apt-repository ppa:pdoes/ppa” instead.

    However, I got errors such as

    Preparing to replace git 1: (using …/git_2%3a1.7.8.3-0avh1~oneiric_i386.deb) …
    mv: `/usr/lib/git-core/git-add.tmp’ and `/usr/lib/git-core/git-add’ are the same file
    dpkg: error processing /var/cache/apt/archives/git_2%3a1.7.8.3-0avh1~oneiric_i386.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Trying to remove git again with sudo apt-get remove git revealee that

    You might want to run ‘apt-get -f install’ to correct these:
    The following packages have unmet dependencies:
    gitk : Depends: git (> 2: but it is not going to be installed
    Depends: git (< 2: but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    In order to resolve these issued, I had to
    sudo apt-get -f remove git-man git-doc gitk
    then I could
    sudo apt-get install git gitk

  • If we run the command

    sudo apt-get install git gitk

    in ubuntu 10.04, which version of git is normally installed??

    • Peter

      I believe in Lucid git is not the git you are looking for, you need to use git-core, but I could be wrong on that one.
      The version that comes with Lucid of git is

  • Sergio Rus

    Thanks for sharing a Git repo for Lucid. So far, Lucid repos still have version!! which is too old for a tool I’d like to install… But now:
    > git –version
    git version


  • thomst

    Thanks for your work.
    I always worked with the ubuntu-package of git, which is good enough for me. But now I’ve upgraded to 12.04 (beta2) and recogniced that the bash-completion doesn’t work within the graphical terminal. Since I’m working productive with git this is kind of annoying, so I tried your build of the newest git-version. Unfortunatly I’ve got the same problem with it. Do you have a hint how to fix it and make my git working allright again?
    That would be wonderful…

    • thomst

      It works!!!
      Well, I’ve upgraded git from your repro, but didn’t started a new shell when tested it…
      Hey, that’s really great. Thank you!

  • flexic

    Will these builds not work on Ubuntu derivatives? Trying to update git on Linux Mint 12 (Lisa):

    Preparing to replace git 1: (using …/git_2%3a1.7.10-0avh1~oneiric_amd64.deb) …
    mv: `/usr/lib/git-core/git-add.tmp’ and `/usr/lib/git-core/git-add’ are the same file
    dpkg: error processing /var/cache/apt/archives/git_2%3a1.7.10-0avh1~oneiric_amd64.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    • Peter

      I don’t know why it doesn’t work. I suggest uninstalling the old git and installing the new version.

      • flexic

        That did it, guess dpkg didn’t like having to uninstall the default version. Doing it manually allowed the package to be installed, thanks as always Peter!

  • bosyber

    Thanks, very useful to have this repository
    Especially since at this moment the official ppa for git doesn’t seem to have git-man version that goes with the newest version of git there (1.7.11~ppa), muon decided to just remove the 1.7.10 versions of git (and tries to be brief so as not to confuse, choosing to be inaccurate instead by not letting me know what the issue is …) leaving only git-man that couldn’t be upgraded, then having the rest of git not upgradable as they depend on a newer version of man. Installing your version 1.7.11 works around that nicely.

  • mrutyunjay

    I have ubuntu10.04 accidently i uninstall the git … I require the default version for work.. so how can i reinstall that default version… i even dont know whic version was there bbefore…

    • bosyber

      mrulyunjay, it might be easiest to disable
      ppa:pdoes/ppa for now (in Software center or what you use to manage repositories); then “apt-get update && apt-get install git ”
      if you need the default version anyway, as that will get it automatically in future, until you have need of newer versions again.

  • For any other Ubuntu noobs like me wondering why they added the repo using the command above but couldn’t get any upgrades, you have to `apt-get update` first as in @bosyber’s comment.

    $ sudo apt-get upgrade git
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following packages have been kept back:
    git git-man git-svn
    The following packages will be upgraded:

    Can someone tell me the significance of ‘git’ and ‘git-man’ packages being ‘held back’… they didn’t get upgraded to 1.7.11?

    • Peter

      Previous versions of Ubuntu used git-core for the packages, at one point they moved to plain git, I can’t remember when that happened. If you installed git on an Ubuntu version which used git-core and upgraded your Ubuntu distro, the upgrade process will still work by git-core.

      You can prevent this by removing all git packages and installing them again and not use git-core, but git instead.

  • do you build with git contrib packages? I am trying to get git subtree which was added to contrib in 1.7.11. Doesn’t seem to exist

    • Peter

      No contrib packages are build, only the core packages and bash_completion is installed.

      • Jakub

        git-subtree is becoming very important command commonly used (at least in community I live). Is there a chance that git-subtree will be moved to git core or that this particular contrib package will be built? It would be very convenient to have git-subtree packaged, please 🙂

  • Mark

    You’ll need to run `sudo apt-get install python-software-properties` to get the `add-apt-repository ` command (on 12.04 server at least).

  • Adrian Caceres

    Are 10.04 packages still available? I added your repo, apt-get doesn’t seem to find an upgrade. For some very sad reason, I need to run on a very old kernel – hence this VM is running 10.04.

    • Adrian Caceres

      I tried it again and it worked. Momentary glitch. Sorry for the bother and thanks so much for doing this.

  • lb1a

    Seems to missing the contrib/git-completion stuff. my bash is complaining about “__git_ps1: command not found” after updating to your ppa git version.

    • Peter

      It’s not missing. Since v1.7.12 the __git_ps1 code has been moved to a separate file

      . It’s no longer in the bash_completion code. To use this file follow the instructions given in the file located at

  • cmoaciopm

    It is a pity. This package is not built with git-p4 support.
    When I invoke “git p4” in command line, it prompted like this
    “fatal: git was built without support for git-p4 (NO_PYTHON=1)”

  • I’m new to running linux, so I apologize for the dumb question, but I just tried running the install above for the ppa, and I still get the same error
    I did this in my shell
    sudo add-apt-repository ppa:pdoes/ppa
    and I get this error

    gpg: keyring `/tmp/tmpntdhf6/secring.gpg’ created
    gpg: keyring `/tmp/tmpntdhf6/pubring.gpg’ created
    gpg: requesting key 4CBEDD5A from hkp server
    gpg: /tmp/tmpntdhf6/trustdb.gpg: trustdb created
    gpg: key 4CBEDD5A: public key “Launchpad PPA for Peter van der Does” imported
    gpg: no ultimately trusted keys found
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)

    so when I run

    sudo apt-get install git

    I still there the error

    Package git is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘git’ has no installation candidate

    I’m running 12.10 Ubuntu, and can’t figure out what’s going on.


    • Peter

      After adding the repository you need to run:

      sudo apt-get update

      • Thanks so much, that help, but now I am getting a
        git: Depends: liberror-perl but it is not installable error
        and that doesn’t seem to be in the apt-get repository

        • Peter

          liberror-perl comes with Ubuntu’s repo. Not sure why you can’t install it.

          • Possible its because I’m in 64bit?

          • Peter

            No I run 64bit myself.

            Try installing liberror-perl through the GUI, it might tell you more on why it can’t install it.

          • Just the same error in the software center, but then the software center says there was a problem, and says it needs to relaunch ( I think that’s a software center issue though, its happened on multiple occasions)

          • Thanks for all the help, I ended up having to find a liberror-perl deb, and install and update that. weird thing was when it did that, it said I was already up to the current version, and it stopped updating it. I was able to do an apt-get install git after that.


  • Kangkan

    Hey! many thanks for your work. appreciate it much!

  • Thank you very much!

  • Scott Leonard

    Argh! Looks like the rc3 breaks google’s repo script. Any way to get 1.8.3?

    Traceback (most recent call last):
    File “/home/vcsadmin/bin/repo”, line 738, in
    File “/home/vcsadmin/bin/repo”, line 705, in main
    File “/home/vcsadmin/bin/repo”, line 234, in _Init
    File “/home/vcsadmin/bin/repo”, line 279, in _CheckGitVersion
    ver_act = tuple(map(int, ver_str.split(‘.’)[0:3]))
    ValueError: invalid literal for int() with base 10: ‘3-rc3’

    • Peter

      Uhm, something must have been wrongly tagged or something. I’ll check it out.

      • Scott Leonard

        Thanks, just got git-core and it delivered git version 1.8.3-rc3 to me on 10.04.

    • Peter

      Yeah git released 1.8.3 without updating their version file.

      • Scott Leonard

        Is there an earlier version I can grab?

        • Peter

          I guess that’s not possible with launchpad 🙁

          Is it for Ubuntu 10.04? Cause I can rebuild the version on Launchpad.

  • Shahbaz


    Thanks for the PPA. Can you please add contrib to your builds? There are some useful git commands that are not included by default, such as `git subtree`. You can find more information here:

  • Your PPA is based on Debian packaging that’s five years old; it was last merged from My PPA ( updates from both upstream and Debian whenever there’s a release from either one. So, for example, it has ‘git subtree’.

    • Peter

      Thank you for the tip. I will update the version on my PPA to include subtree and mediawiki.

      I update the debian directory manually, not with git merging from the Debian git. Burned myself a few times doing a merge with Debian in the past.